Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Unable to access indexes via access keys or api key because "given key is invalid"

Chris Mar 10, 2017 11:34PM +03

I'm test driving Searchly so that my company can pick between it and Algolia for a project. I signed up for an account and started stepping through the documentation.

I created an index, created an access key, gave access to the key for the index, saved it, viewed the details on the key to confirm that the key did indeed have access to the index (it says it does), and then tried viewing the index data via the rest api url:

https://site:{mynewlycreatedaccesskey}@api.searchbox.io/test-index

(I know that's the index name noted in the documentation, I created an index with the same name b/c the name seems appropriate for a test).

When I fire that request I get the following result:

{"status":"error", "message":"given key is invalid"}


I've tried it from several rest api clients with no change.

I then tried the same url but using the full access API key just to see if it was a problem with the access key. I received the same result.

I checked both the elasticsearch and crawler logs and they're empty.

I have two questions:
1. Why can't I get in?
2. Where can I go to see details on the failed connection?

Thanks,

Chris

Up 0 rated Down
Ferhat Sobay Mar 11, 2017 12:19AM +03 Searchly Agent
Hi Chris,

Your endpoint should be set at dashboard, are you sure it is api.searchbox.io?

Best,
Ferhat
Up 0 rated Down
Chris Mar 11, 2017 12:37AM +03
Yeah one of my coworkers and I looked at the issue together and notice that the connection url specified in the dashboard is different that what's given in the documentation.

We used the following connection url provided by the dashboard and it worked:

https://{keyname}:{accesskey}@nori-us-east-1.searchly.com/test-index

I was thrown off by the documentation here http://docs.searchly.com/documentation/developer-api-guide/

which suggests that API calls be made in the format:

http://site:{apiKey}@api.searchbox.io/{indexName}

I'm good to continue the evaluation now. Thanks for getting back to me.

Chris

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
support@searchly.com
http://assets0.desk.com/
false
searchboxio
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete