Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Kibana Request Timeout after 3000ms

Mitchell Feb 18, 2018 08:19PM +03

How's it going guys ?

Trying to hook up a kibana instance running on AWS EC-2 but for some reason it's not able to connect to the searchly ES instance. Error I'm getting is "Request Timeout after 3000ms"

Kibana version is kibana-6.2.1 and my kibana.yml is below.

Any clue how can I fix this ?


root@replaced:/tmp# cat /etc/kibana/kibana.yml|grep -v '#'
server.host: "0.0.0.0"
elasticsearch.url: "http://replaced"
elasticsearch.username: "replaced"
elasticsearch.password: "replaced"
elasticsearch.ssl.verificationMode: none
logging.verbose: true

3 Community Answers

Best Answer
Ferhat Sobay Feb 20, 2018 10:09PM +03

Hi Mitchell,

We have deployed a fix but due to latest changes at Kibana setup requires some tricks to make it run but it runs. Please take into account we are constantly upgrading minor ES versions so you may need to adopt your Kibana version as well.

Create a index named ".kibana" for Kibana configuration at Searchly.

at kibana.yml;

elasticsearch.url: https://yxyz.searchly.com:443 or http://yxyz.searchly.com:80 # with port information


Unfortunately setting username and password does not work at kibana for http basic authentication. What you need to do is setting custom header;

elasticsearch.customHeaders: {"Authorization" :"Basic c2l0ZTo0OTY2D2RkZmIzNzAzMTE2ZDcxNjM2ODE5MGM2MDM1MA=="}

Value of authorization header contains "Basic" and Base64 encoded username:password string. To get that you can use chrome/firefox developer console;

btoa("username:password")

will give you base64 string similar to "c2l0ZTo0OTY2D2RkZmIzNzAzMTE2ZDcxNjM2ODE5MGM2MDM1MA=="

Run Kibana and it will work.

Best,
Ferhat

View in conversation


Up 0 rated Down
Ferhat Sobay Feb 18, 2018 11:53PM +03 Searchly Agent
Hi Mitchell,

We are doing fine and glad to see version 6 issues :) start to show up.

I'm checking the issue and will inform you after figuring out what is going on.

Best,
Ferhat
Up 0 rated Down
Ferhat Sobay Best Answer Feb 20, 2018 10:09PM +03 Searchly Agent
Hi Mitchell,

We have deployed a fix but due to latest changes at Kibana setup requires some tricks to make it run but it runs. Please take into account we are constantly upgrading minor ES versions so you may need to adopt your Kibana version as well.

Create a index named ".kibana" for Kibana configuration at Searchly.

at kibana.yml;

elasticsearch.url: https://yxyz.searchly.com:443 or http://yxyz.searchly.com:80 # with port information


Unfortunately setting username and password does not work at kibana for http basic authentication. What you need to do is setting custom header;

elasticsearch.customHeaders: {"Authorization" :"Basic c2l0ZTo0OTY2D2RkZmIzNzAzMTE2ZDcxNjM2ODE5MGM2MDM1MA=="}

Value of authorization header contains "Basic" and Base64 encoded username:password string. To get that you can use chrome/firefox developer console;

btoa("username:password")

will give you base64 string similar to "c2l0ZTo0OTY2D2RkZmIzNzAzMTE2ZDcxNjM2ODE5MGM2MDM1MA=="

Run Kibana and it will work.

Best,
Ferhat
Up 0 rated Down
Mitchell Feb 21, 2018 01:44AM +03
Much appreciated, Ferhat. Works perfect.

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
support@searchly.com
http://assets3.desk.com/
false
searchboxio
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete